Author Topic: Change minimum required database version.  (Read 1080 times)

Offline archer

  • Overlord
  • ******
  • Posts: 24
  • Helpful: +5/-0
Change minimum required database version.
« on: 2016-08-21, 03:41:15 PM »
We have decided to increase the minimum required version of DBMS to the equivalent of MySQL 5.6 (currently it is 5.5). MariaDb does not follow MySQL's versioning numbers after 5.5 so this might lead to some confusion. Version 10.0 of MariaDb is equivalent to MySQL 5.6 but has additional features not available in MySQL.
When you migrate, you may want to upgrade to the latest GA version of your application (currently 5.7 and 10.1) to avoid having to do this again in the foreseeable future.

We will not be making this change immediately, but would like to give all users as much warning as possible so that they can migrate to the newer version of their preferred application in a planned and unhurried manner. Whether it will be weeks or months away has not been decided yet, but it will not be before the October 2016 release update, nor later than the start of 2017.

For information on migrating to a newer version please see the documentation of your preferred application. ALWAYS back up your data before migrating.

Support my tech addiction.

Offline nrk666

  • Junior Indexer
  • **
  • Posts: 40
  • Helpful: +0/-0
Re: Change minimum required database version.
« Reply #1 on: 2016-09-13, 10:00:50 AM »
Side note, I was messing around with changing over to MariaDB 10 and the Sphinx Engine is no longer enabled by default (but is still included). I had to issue this command to install the Sphinx Engine Module :

mysql> INSTALL SONAME 'ha_sphinx';

Until I did that, every step of the sphinxsearch install looked like it was working fine, but no search results were coming up. After running that command, everything started working like a champ.

(Ubuntu 16.04 + SphinxSearch 2.2.11 + DEV branch)