Author Topic: 0.6.4.0 Release Notes  (Read 2107 times)

Offline Wally73

  • Overlord
  • ******
  • Posts: 260
  • Helpful: +28/-1
  • i'm nuts
0.6.4.0 Release Notes
« on: 2016-09-05, 03:12:08 AM »
0.6.4.0 2016-09-05
Changes:
   * Refactored our yEnc code to use a single class. Lithium adapters are used for the available
    methods, the best available adapter is automatically configured as the default.
     No user configuration should be needed, except for the path to ydecode in the settings as
    before. simple_php_yen_decode can be removed from that setting for those using it, as the
    extension is automatically detected if available.
     For PHP 7.0 users, a new extension is available to replace simple_php_yenc_decode (which
    cannot be compiled for PHP 7+). This extension is also available for PHP 5.6.
     Those familiar with Zephir and able to compile the extension themselves, can do so from this
    repository: https://github.com/niel/php-yenc
     If you can not compile, and are a trusting soul, precompiled versions, in a .deb file, can be
    downloaded from:
       https://github.com/niel/php-yenc/releases/download/v1.0.0/php5.6-yenc_1.0.0-4_amd64.deb
       https://github.com/niel/php-yenc/releases/download/v1.0.0/php7.0-yenc_1.0.0-4_amd64.deb
     The deb package assumes that PHP 5/7 is installed with the php5.6-*/php7.0-* style of
    packaging it will not work correctly with the php5-*/php7-* style (extension should install,
    but the ini files to load it will be in the wrong locations, so you'll have to correct them).
   * Update hint for yydecode setting in site-edit.

Fixed:
   * Sorting arrows on admin->user-list page.
   * Update isTV regex to match full season releases (PR 2244).
« Last Edit: 2017-03-14, 03:52:38 AM by Wally73 »

Offline dertbv

  • Junior Indexer
  • **
  • Posts: 33
  • Helpful: +1/-0
Re: 0.6.4.0 Release Nots
« Reply #1 on: 2016-12-19, 07:33:48 AM »
I assume that this is the reason I am showing these errors..  [19-Dec-2016 10:19:02 America/New_York] PHP Warning:  PHP Startup: simple_php_yenc_decode: Unable to initialize module
Module compiled with module API=20121212
PHP    compiled with module API=20131226
These options need to match

I am running v0.6.7 on Ubuntu 14.05 PHP 5.6.23.  How do I go about resolving this..I have removed the line from the settings..

I was able to resolve the issue by commenting out the line in the config.d file...
« Last Edit: 2016-12-19, 12:45:27 PM by dertbv »

Offline Darius

  • Enforcer
  • *****
  • Posts: 120
  • Helpful: +7/-1
Re: 0.6.4.0 Release Nots
« Reply #2 on: 2016-12-20, 02:27:10 AM »
You need to recompile simple_php_yenc_decode, follow the guide from source: https://github.com/kevinlekiller/simple_php_yenc_decode

Offline dertbv

  • Junior Indexer
  • **
  • Posts: 33
  • Helpful: +1/-0
Re: 0.6.4.0 Release Nots
« Reply #3 on: 2016-12-20, 05:47:52 AM »
Thanks for the link all squared away now!