Author Topic: White screen in browser when <local.ip>/install  (Read 97 times)

Offline RoddyJoff

  • Newbie
  • *
  • Posts: 4
  • Helpful: +0/-0
White screen in browser when <local.ip>/install
« on: 2018-06-03, 07:50:05 AM »
Hello,

I hope someone is able to help.

I have installed nZEDb on my Raspberry Pi 2B using this guide

https://www.htpcguides.com/install-nzedb-raspberry-pi-private-usenet-indexing/

with no apparent errors but when I type <local.ip>/install it appears that the session is established but all I have is a white screen.

Also, if I try to access phpmyadmin on the same address and input my username/password I receive:

#1045 Cannot log in to the MySQL server

I am using a Mac Safari browser to make the connection.

Anyone any ideas?

Cheers.

Offline Wally73

  • Overlord
  • ******
  • Posts: 257
  • Helpful: +28/-1
  • i'm nuts
Re: White screen in browser when <local.ip>/install
« Reply #1 on: 2018-06-04, 01:22:51 AM »
that guide uses an ancient version of php

You NEED php 7.x (7.1.x works fine with nZEDb)

Offline RoddyJoff

  • Newbie
  • *
  • Posts: 4
  • Helpful: +0/-0
Re: White screen in browser when <local.ip>/install
« Reply #2 on: 2018-06-04, 03:20:00 AM »
Hi Wally,

Many thanks for your reply.

I followed this guide:

https://www.cyberciti.biz/faq/installing-php-7-on-debian-linux-8-jessie-wheezy-using-apt-get/

and during the installation encountered the following errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-openssl-dev : Depends: libkrb5-dev but it is not going to be installed
                        Depends: librtmp-dev but it is not going to be installed
                        Depends: libssh2-1-dev but it is not going to be installed
 libxml2-dev : Depends: libxml2 (= 2.8.0+dfsg1-7+wheezy12) but 2.9.1+dfsg1-5+deb8u6 is to be installed
E: Unable to correct problems, you have held broken packages.


The installation continued but finally halted here:


checking for bison version... invalid
configure: WARNING: This bison version is not supported for regeneration of the Zend/PHP parsers (found: none, min: 204, excluded: ).
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
configure: error: bison is required to build PHP/Zend when building a GIT checkout!
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.


I am using an RPI2B with Wheezy

You have probably guessed by now I’m a bit of a Noob - are you able to offer any help please?

Many thanks.

Offline Wally73

  • Overlord
  • ******
  • Posts: 257
  • Helpful: +28/-1
  • i'm nuts
Re: White screen in browser when <local.ip>/install
« Reply #3 on: 2018-06-04, 04:39:38 AM »
I don't know anything about Rasperry's

but try to use jessie or stretch as its OS

Offline RoddyJoff

  • Newbie
  • *
  • Posts: 4
  • Helpful: +0/-0
Re: White screen in browser when <local.ip>/install
« Reply #4 on: 2018-06-04, 05:27:25 AM »
Will do, many thanks.