Author Topic: Need to run update_binaries Otherwise the group is dead error  (Read 1292 times)

Offline pdupreez

  • Junior Indexer
  • **
  • Posts: 19
  • Helpful: +0/-0
I have been getting an error "Error: You need to run update_binaries on a.b.ebook. Otherwise the group is dead, you must disable it."

I have (previously) already run the update_binaries against the newsgroup, but get nothing
Code: [Select]
bash-4.4# php update_binaries.php alt.binaries.ebook
Updating group: alt.binaries.ebook
Processing alt.binaries.ebook

Searching for an approximate article number for group alt.binaries.ebook 1 days back.
----------------------+-++
Found article #32265952 which has a date of Fri, 28 Sep 2018 11:52:25 -0500, vs wanted date of Fri, 28 Sep 2018 11:29:05 -0500. Difference from goal is -0 days.
No new articles for alt.binaries.ebook (first 32,265,952, last 32,265,952, grouplast 0, total 0)
Server oldest: 319 Server newest: 32,265,956 Local newest: 0

I have reset the group, and purged it, but it doesn't show up as being read in my group settings



Offline noobg

  • Newbie
  • *
  • Posts: 2
  • Helpful: +0/-0
Re: Need to run update_binaries Otherwise the group is dead error
« Reply #1 on: 2018-11-16, 12:47:32 PM »
The easiest way to resolve this that I've found is to open the admin panel, under site settings choose groups and then view the group that's causing an issue.  I found that this occurred when the "First Record ID" (or maybe it's called Oldest Record in previous versions) was too low, which caused the program to assume there were no more releases earlier than that. 

The solution is to make the "First Record" a later number.  If you haven't backfilled too much yet, set it to the "Last Record ID".  Hopefully it'll work then. Also, when you choose a new group don't immediately select backfill.  Wait for it to cycle for a bit as it updates the latest binaries and then choose backfill once it has established a first/last ID.