Recent Posts

Pages: [1] 2 3 ... 10
1
Support / Re: nZEDb on Raspberry STRETCH
« Last post by kaibosh on 2018-06-12, 09:37:33 AM »
Minimum memory requirement is 4Gb. Even if you managed to get nzedb installed, it would run so damn slow due the shared USB/network config the RPi's have.
2
Support / nZEDb on Raspberry STRETCH
« Last post by RoddyJoff on 2018-06-09, 10:26:00 AM »
Hi,

I have been trying to install nZEDb onto my RPI 2B+ for the last week or so and am driving myself mad!

I have tried Wheezy, Jessie and finally the latest Stretch.

First of all I used this:

https://linuxconfig.org/how-to-install-a-lamp-server-on-debian-9-stretch-linux

to install LAMP with no errors.

Everything works including the default Apache index.html file when I connect from my Mac at 192.168.0.20

Next I installed nZEDb using the following command:

sudo git clone https://github.com/nZEDb/nZEDb.git /var/www/nZEDb

and this is where it starts to wrong.

I discovered that the default web directory on Stretch differs to that of Wheezy. The original nZEDb installation expects /var/www but it now is /var/www/html on Stretch.

I therefore attempted to ‘fix’ this by changing sites-available and DocumentRoot and other things I cannot remember, getting myself into an endless loop.

If I install a simple index.html file in /var/www/nZEDb before making any changes then 192.168.0.20 works insofar that I get the message in the index.html file so why doesn’t 192.168.0.20/install work, having removed the index.html file?

I am at a loss to say the least. I am about to re-install Apache to set everything to a base/normal state but after that don’t know where to go.

Should I have install nZEDb in /var/www/html rather than try to reconfigure?

If not how do I fix it?

Many thanks in advance ;-)

EDIT

I think a simpler question would be, in which directory should I execute this command:

sudo git clone https://github.com/nZEDb/nZEDb.git


/var/www or var/www/html or /var/www/nZEDb


Many thanks.
3
Support / Re: White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-04, 05:27:25 AM »
Will do, many thanks.
4
Support / Re: White screen in browser when <local.ip>/install
« Last post by Wally73 on 2018-06-04, 04:39:38 AM »
I don't know anything about Rasperry's

but try to use jessie or stretch as its OS
5
Support / Re: White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-04, 03:20:00 AM »
Hi Wally,

Many thanks for your reply.

I followed this guide:

https://www.cyberciti.biz/faq/installing-php-7-on-debian-linux-8-jessie-wheezy-using-apt-get/

and during the installation encountered the following errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-openssl-dev : Depends: libkrb5-dev but it is not going to be installed
                        Depends: librtmp-dev but it is not going to be installed
                        Depends: libssh2-1-dev but it is not going to be installed
 libxml2-dev : Depends: libxml2 (= 2.8.0+dfsg1-7+wheezy12) but 2.9.1+dfsg1-5+deb8u6 is to be installed
E: Unable to correct problems, you have held broken packages.


The installation continued but finally halted here:


checking for bison version... invalid
configure: WARNING: This bison version is not supported for regeneration of the Zend/PHP parsers (found: none, min: 204, excluded: ).
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
configure: error: bison is required to build PHP/Zend when building a GIT checkout!
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.


I am using an RPI2B with Wheezy

You have probably guessed by now I’m a bit of a Noob - are you able to offer any help please?

Many thanks.
6
Announcements / Release 0.8.7.0 2018-06-04
« Last post by Wally73 on 2018-06-04, 01:24:03 AM »
0.8.7.0 2018-06-04
Changed:
   * Increase size of 'xref' column in collections' tables due to some larger sizes reported.

Fixed:
   * Replacing last use of each() in nZEDb code. Note that two libraries (forkdaemon and
    guzzlehttp/promises) still use it however.


0.8.6.0 2018-05-07
Added:
   * tpg' option (to './zed verify tables' sub-command), which checks for missing tables of active
    groups and creates them. It does not delete tables of inactive groups.

Fixed:
   * Issue where the date after 'release have been disabled/terminated by Releases' was printed as
    the format string instead of the formatted numbers.


0.8.5.2 2018-04-05
Fixed:
   * Actually merge in the PHPMailer fix.


0.8.5.1 2018-04-05
Fixed:
   * PHPMailer 'Call to a member function isHTML() on null' error.
7
Support / Re: White screen in browser when <local.ip>/install
« Last post by Wally73 on 2018-06-04, 01:22:51 AM »
that guide uses an ancient version of php

You NEED php 7.x (7.1.x works fine with nZEDb)
8
Support / White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-03, 07:50:05 AM »
Hello,

I hope someone is able to help.

I have installed nZEDb on my Raspberry Pi 2B using this guide

https://www.htpcguides.com/install-nzedb-raspberry-pi-private-usenet-indexing/

with no apparent errors but when I type <local.ip>/install it appears that the session is established but all I have is a white screen.

Also, if I try to access phpmyadmin on the same address and input my username/password I receive:

#1045 Cannot log in to the MySQL server

I am using a Mac Safari browser to make the connection.

Anyone any ideas?

Cheers.
9
Support / Re: [SOLVED] yEncs being dropped / par2 split from release
« Last post by henryford on 2018-05-30, 08:55:39 AM »
Still feel like it should pick them anyhow.

But I can confirm that with changing my par2-naming scheme, posts are now again fully indexed.
10
Support / Re: [SOLVED] yEncs being dropped / par2 split from release
« Last post by Wally73 on 2018-05-30, 03:39:34 AM »
normal post method is in the form of

Code: [Select]
name - [01/10] - filename - yenc
Pages: [1] 2 3 ... 10