Recent Posts

Pages: 1 [2] 3 4 ... 10
Support / nZEDb on Raspberry STRETCH
« Last post by RoddyJoff on 2018-06-09, 10:26:00 AM »

I have been trying to install nZEDb onto my RPI 2B+ for the last week or so and am driving myself mad!

I have tried Wheezy, Jessie and finally the latest Stretch.

First of all I used this:

to install LAMP with no errors.

Everything works including the default Apache index.html file when I connect from my Mac at

Next I installed nZEDb using the following command:

sudo git clone /var/www/nZEDb

and this is where it starts to wrong.

I discovered that the default web directory on Stretch differs to that of Wheezy. The original nZEDb installation expects /var/www but it now is /var/www/html on Stretch.

I therefore attempted to ‘fix’ this by changing sites-available and DocumentRoot and other things I cannot remember, getting myself into an endless loop.

If I install a simple index.html file in /var/www/nZEDb before making any changes then works insofar that I get the message in the index.html file so why doesn’t work, having removed the index.html file?

I am at a loss to say the least. I am about to re-install Apache to set everything to a base/normal state but after that don’t know where to go.

Should I have install nZEDb in /var/www/html rather than try to reconfigure?

If not how do I fix it?

Many thanks in advance ;-)


I think a simpler question would be, in which directory should I execute this command:

sudo git clone

/var/www or var/www/html or /var/www/nZEDb

Many thanks.
Support / Re: White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-04, 05:27:25 AM »
Will do, many thanks.
Support / Re: White screen in browser when <local.ip>/install
« Last post by Wally73 on 2018-06-04, 04:39:38 AM »
I don't know anything about Rasperry's

but try to use jessie or stretch as its OS
Support / Re: White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-04, 03:20:00 AM »
Hi Wally,

Many thanks for your reply.

I followed this guide:

and during the installation encountered the following errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-openssl-dev : Depends: libkrb5-dev but it is not going to be installed
                        Depends: librtmp-dev but it is not going to be installed
                        Depends: libssh2-1-dev but it is not going to be installed
 libxml2-dev : Depends: libxml2 (= 2.8.0+dfsg1-7+wheezy12) but 2.9.1+dfsg1-5+deb8u6 is to be installed
E: Unable to correct problems, you have held broken packages.

The installation continued but finally halted here:

checking for bison version... invalid
configure: WARNING: This bison version is not supported for regeneration of the Zend/PHP parsers (found: none, min: 204, excluded: ).
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
configure: error: bison is required to build PHP/Zend when building a GIT checkout!
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.

I am using an RPI2B with Wheezy

You have probably guessed by now I’m a bit of a Noob - are you able to offer any help please?

Many thanks.
Announcements / Release 2018-06-04
« Last post by Wally73 on 2018-06-04, 01:24:03 AM » 2018-06-04
   * Increase size of 'xref' column in collections' tables due to some larger sizes reported.

   * Replacing last use of each() in nZEDb code. Note that two libraries (forkdaemon and
    guzzlehttp/promises) still use it however. 2018-05-07
   * tpg' option (to './zed verify tables' sub-command), which checks for missing tables of active
    groups and creates them. It does not delete tables of inactive groups.

   * Issue where the date after 'release have been disabled/terminated by Releases' was printed as
    the format string instead of the formatted numbers. 2018-04-05
   * Actually merge in the PHPMailer fix. 2018-04-05
   * PHPMailer 'Call to a member function isHTML() on null' error.
Support / Re: White screen in browser when <local.ip>/install
« Last post by Wally73 on 2018-06-04, 01:22:51 AM »
that guide uses an ancient version of php

You NEED php 7.x (7.1.x works fine with nZEDb)
Support / White screen in browser when <local.ip>/install
« Last post by RoddyJoff on 2018-06-03, 07:50:05 AM »

I hope someone is able to help.

I have installed nZEDb on my Raspberry Pi 2B using this guide

with no apparent errors but when I type <local.ip>/install it appears that the session is established but all I have is a white screen.

Also, if I try to access phpmyadmin on the same address and input my username/password I receive:

#1045 Cannot log in to the MySQL server

I am using a Mac Safari browser to make the connection.

Anyone any ideas?

Support / Re: [SOLVED] yEncs being dropped / par2 split from release
« Last post by henryford on 2018-05-30, 08:55:39 AM »
Still feel like it should pick them anyhow.

But I can confirm that with changing my par2-naming scheme, posts are now again fully indexed.
Support / Re: [SOLVED] yEncs being dropped / par2 split from release
« Last post by Wally73 on 2018-05-30, 03:39:34 AM »
normal post method is in the form of

Code: [Select]
name - [01/10] - filename - yenc
Support / [SOLVED] yEncs being dropped / par2 split from release
« Last post by henryford on 2018-05-29, 06:24:44 AM »
Hey guys,

I'm running on with php 7.0. I have a weird issue since upgrading (I actually completely reset my installation):
There are yEnc posts (my own ones) being dropped when updating binaries. This occurs if I post my stuff with the Subject:
In that case, when activating the "not_yenc.log", it get's filled with entries that those headers have been dropped.

The weird thing is, when using this subject line:
[SEGMENT/TOTALSEGMENT] "FILENAME" yEnc (part/totalparts)
(note the extra space after yEnc), the releases gets indexed after the the "Delay Time Check" has passed. The release misses it's par2-volume files, those are being created as extra, single releases. The main par2-file is in the release, that also contains the rars. I am completely stumped as to what is happening here.

Any ideas anybody?

I think I found the problem - it's with the par process.

Through a recent update to my par-client, the naming scheme of the volfiles changed ever so slightly. They were now named:
instead of the previous

By setting an extra option, I'm back to the previous behaviour. That hopefully fixes this.
Pages: 1 [2] 3 4 ... 10