Author Topic: [SOLVED] Stuck on install/step2.php  (Read 4236 times)

Offline josh4trunks

  • Decent Indexer
  • ***
  • Posts: 70
  • Helpful: +2/-0
[SOLVED] Stuck on install/step2.php
« on: 2014-10-08, 09:34:57 am »
hey guys, thanks in advance for any help you provide.

I'm hitting an issue on step 2 of the install pages. when I enter in correct mysql credentials I get the following error. (with debuging enabled)
Code: [Select]
Base table or view not found: 1146 Table 'nzedb.settings' doesn't exist
If I put in bad mysql credentials the page doesn't submit so that's not an issue.
I noticed the nzedb database is being created. so the initial part of the script is running.
I set permissions to my nZEDb directory to 777 (recursively) to rule out mysqld not being able to read the file.
I tried submitting root mysql credentials to rule out mysql permission issues and I get the same error.
I was able to set everything up successfully in October 2013 so it must be something new I'm hitting.

Specs
OS =  FreeBSD 9.2 Jail
webserver = nginx + php-fpm
php = php5.5
database = mariadb5.5

Does anyone have guidance of how I could run the steps in part 2 manually, maybe I can track down the issue that way.

EDIT
I fixed this by making sure php new the path to git
« Last Edit: 2014-10-11, 12:29:45 pm by josh4trunks »

Offline NasKar

  • Junior Indexer
  • **
  • Posts: 11
  • Helpful: +0/-0
Re: [SOLVED] Stuck on install/step2.php
« Reply #1 on: 2016-04-23, 11:47:20 am »
Josh,
I'm also stuck at step 2 (create database) I get
The 192.168.1.157 page isn’t working

192.168.1.157 is currently unable to handle this request.
500

How did you make sure php knew the path to git

I don't know how to set debugging on for mariadb.  Tried to google but not clear.

Offline Wally73

  • Overlord
  • ******
  • Posts: 269
  • Helpful: +31/-1
  • i'm nuts
Re: [SOLVED] Stuck on install/step2.php
« Reply #2 on: 2016-04-24, 04:02:04 pm »
Code: [Select]
ln -s /usr/local/bin/git /usr/bin/git
symlink did the trick i saw somewhere (added it here for future reference for FreeBSD users)

Offline NasKar

  • Junior Indexer
  • **
  • Posts: 11
  • Helpful: +0/-0
Re: [SOLVED] Stuck on install/step2.php
« Reply #3 on: 2016-04-24, 05:10:12 pm »
For those that need the actual command.
ln -s /usr/local/bin/git /usr/bin/git

Offline fillister

  • Newbie
  • *
  • Posts: 2
  • Helpful: +0/-0
Re: [SOLVED] Stuck on install/step2.php
« Reply #4 on: 2017-07-15, 02:38:00 pm »
hello all,

I've installed nzedb using the guide at https://www.linuxbabe.com/ubuntu/set-up-nzedb-usenet-indexer-ubuntu-16-0417-04

I'm hung up at step two "database setup" when I enter the data per the instructions i get the following error and a white page

http://192.168.1.170/install/step2.php?

Ive tried the solution found in the forum:  ln -s /usr/local/bin/git /usr/bin/git

And i get the following output: ln: failed to create symbolic link '/usr/bin/git': File exists

any help to get this resolved would be greatly appreciated

Thanks


Offline kaibosh

  • Overlord
  • ******
  • Posts: 161
  • Helpful: +18/-0
Re: [SOLVED] Stuck on install/step2.php
« Reply #5 on: 2017-07-17, 04:28:05 am »
That install guide is out-of-date and the project sadly lacks someone to complete the official ubu16/17 guide.

Suggest you review the changelog for recent changes and turn on logging in configuration/settings.php. If you don't get further it's best to stop by the IRC channel as there's normally someone around to help out.