Author Topic: [Solved] Can't run Install  (Read 1273 times)

Offline genebeck

  • Newbie
  • *
  • Posts: 1
  • Helpful: +0/-0
[Solved] Can't run Install
« on: 2021-01-03, 06:07:19 pm »
I have a new build on Ubuntu 18.04.  Everything work up to the point of http/xxx/install.   I get a http 500 error.  After digging into the error logs I find it is complaining about Lithium not being found.  I checked the libraries folder and it is empty.

The question is, have I messed up a step or has the git clone failed?  Here is the log:

Quote
[Sun Jan 03 14:25:55.923581 2021] [php7:warn] [pid 10130] [client 192.168.0.50:63701] PHP Warning:  include_once(/var/www/nZEDb/libraries/lithium/core/Libraries.php): failed to open stream: No such file or directory in /var/www/nZEDb/app/config/bootstrap/libraries.php on line 74
[Sun Jan 03 14:25:55.923648 2021] [php7:warn] [pid 10130] [client 192.168.0.50:63701] PHP Warning:  include_once(): Failed opening '/var/www/nZEDb/libraries/lithium/core/Libraries.php' for inclusion (include_path='.:/usr/share/php') in /var/www/nZEDb/app/config/bootstrap/libraries.php on line 74
[Sun Jan 03 14:25:55.923737 2021] [php7:error] [pid 10130] [client 192.168.0.50:63701] PHP Fatal error:  Uncaught ErrorException: Lithium core could not be found.  Check the value of LITHIUM_LIBRARY_PATH in /var/www/nZEDb/app/config/bootstrap/libraries.php.  It should point to the directory containing your /libraries directory. in /var/www/nZEDb/app/config/bootstrap/libraries.php:78\nStack trace:\n#0 /var/www/nZEDb/app/config/bootstrap.php(39): require_once()\n#1 /var/www/nZEDb/www/smarty.php(22): require_once('/var/www/nZEDb/...')\n#2 /var/www/nZEDb/www/install/index.php(7): require_once('/var/www/nZEDb/...')\n#3 {main}\n  thrown in /var/www/nZEDb/app/config/bootstrap/libraries.php on line 78
 

After some much need help this issue was resolved.  I will share what I missed in case somebody else runs into this problem.

There are actually 2 issues.  The first was I did not run the compose install command to download the rest of the code.  The 2nd problem was that I had composer v2 NOT v1.   There is a direct download at the bottom of the compose download for manual download of the latest version 1.  I copied the link then in putty used wget to save the composer phar file into the nZEDb root folder and then run the app.  I opted not to make composer global.

Quote
wget https://getcomposer.org/composer-1.phar
php composer-1.php install --prefer-source
« Last Edit: 2021-01-05, 08:47:44 am by Wally73 »

Offline Wally73

  • Overlord
  • ******
  • Posts: 270
  • Helpful: +31/-1
  • i'm nuts
Re: Can't run Install
« Reply #1 on: 2021-01-05, 08:47:19 am »