Author Topic: Upgraded to latest release, getting errors about par2info  (Read 1803 times)

Offline homerdoh

  • Junior Indexer
  • **
  • Posts: 11
  • Helpful: +0/-0
Upgraded from 0.6.3.2 to 0.7.3.3, (hopefully) did all the necessary updates in ReleaseNotes for each version in between.

The rarinfo files seem to be missing, I'm getting this in php_errors.log:

[25-Jul-2017 15:46:15 Europe/Stockholm] PHP Warning:  include(/var/www/nZEDb/app/libraries/composer/../../../libs/zeebinz/rarinfo/par2info.php): failed to open stream: No such file or directory in /var/www/nZEDb/app/libraries/composer/ClassLoader.php on line 444
[25-Jul-2017 15:46:15 Europe/Stockholm] PHP Warning:  include(): Failed opening '/var/www/nZEDb/app/libraries/composer/../../../libs/zeebinz/rarinfo/par2info.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/nZEDb/app/libraries/composer/ClassLoader.php on line 444
[25-Jul-2017 15:46:15 Europe/Stockholm] PHP Fatal error:  Class 'Par2Info' not found in /var/www/nZEDb/nzedb/processing/PostProcess.php on line 109

I've tried running zed update again, says I'm up to date:

Already up-to-date.
Checking database version...
Db: 482,        File: 482
Up to date.
The Smarty compiled template cache has been cleared for you

Any ideas?

Offline homerdoh

  • Junior Indexer
  • **
  • Posts: 11
  • Helpful: +0/-0
Re: Upgraded to latest release, getting errors about par2info
« Reply #1 on: 2017-07-26, 01:34:04 am »
Manually added rarinfo from https://github.com/zeebinz/rarinfo to .../libs/zeebinz/rarinfo/, seems to work.

Offline Wally73

  • Overlord
  • ******
  • Posts: 270
  • Helpful: +31/-1
  • i'm nuts
Re: Upgraded to latest release, getting errors about par2info
« Reply #2 on: 2017-07-26, 01:42:47 am »
seems composer stuff is messed up

do composer install in your main nzedb dir (should fix the missing stuff)

Offline homerdoh

  • Junior Indexer
  • **
  • Posts: 11
  • Helpful: +0/-0
Re: Upgraded to latest release, getting errors about par2info
« Reply #3 on: 2017-07-26, 05:04:49 am »
Thanks, composer install fixed a bunch of missing stuff.